That Quail Place Forum

Raising Gamebirds => Brooding and Raising => Topic started by: duck nutt on April 25, 2004, 09:56:56 AM

Title: temperature problems
Post by: duck nutt on April 25, 2004, 09:56:56 AM
maybe this is something easy yo understand, and i'm just not getting it, but,  I have a GQF sportsman incubator...I have 2 thermometers in it right now....one just for the temp, and the other for the humidity(but i don't have the wet wick connected right now, so it's just giving me the temp inside)  anyway, i decided to test my thermometers yesterday and lpaced a regular mercury thermometer inside the incubator(the kind ya stick under your tongue)   anyway, with both of my other thermometers reading 100, the mercury one inside read 102!!  i set it on the eggs...  can anyone tell me why, other than my other 2 thermometers are wrong..i've hatched birds with them before, just last week, 40 chickens and 10 quail...  help!.....i just set 8 wild turkey eggs that i really wanna hatch

duck_nutt
Title: temperature problems
Post by: Don McGowan on April 26, 2004, 08:10:01 AM
With my sportsman I find that the Temp varies about 2 degrees depending on which thermometer I use also. How have your hatches been in the past?
I think mine is set just a little high in temp because the hatches are about 12 hours early but the hatches have been great and the percentage is way up there compaired to the foam Incubator.  So I'm not touching a thing and I have quit worring about the temp difference I just check the dial and go on.
Title: temperature problems
Post by: duck nutt on April 26, 2004, 10:17:33 AM
thanks don...i posted this question on another site, backyard chickens, and got a similar response..I also was told that you're not supposed to use mercury thermometers in incubators cause they tend to register higher temps.....maybe it's because you leave the whole thermometer in the box for so long ..anyway, like you said, i'm gonna keep watchin the temp i've always used, and run with it....past hatches have worked well...wish i had never put that mercury thermometer in there!

duck nutt
Title: temperature problems
Post by: CHARLIE on April 26, 2004, 09:25:23 PM
I AGREE WITH DON, AS I TO HAVE 2 THERMOMETERS AND THEY ARE ABOUT 2-3 DEGREES APART. I JUST GO BY WHAT THE DIAL SAYS, USED THE SAME ONE ALL LAST YEAR NEVER HAD TO ADJUST AND HAD GOOD - GREAT HATCHES.
                      CHARLIE
                       BACKYARD GAMEBIRD FARM
                        DELAWARE