Website Main Page
Forum Main Page

Welcome, Guest. Please login or register.
October 24, 2020, 07:50:42 AM

Login with username, password and session length
Search:     Advanced search

Thank you for making us one of the highest ranking gamebird sites on the internet!
42418 Posts in 6015 Topics by 2375 Members
Latest Member: jg102
* Home Help Search Calendar Login Register
+  That Quail Place Forum
|-+  Raising Gamebirds
| |-+  Incubation
| | |-+  Bad Egg Quality/or loss of Electricity????
« previous next »
Pages: [1] Go Down Print
Author Topic: Bad Egg Quality/or loss of Electricity????  (Read 2102 times)
wvgirl
Guest
« on: September 17, 2004, 08:55:06 PM »

I had 200 eggs in my incubator and every day the electric was off but I don't know for how long. Alot of the eggs never hatched.I have hatched out many eggs before without any problems. I ended up with 52 healthy chicks. Most of the ones that did hatch never stood up. They lay on their sides and just twirl around and I had to destroy them. Was this just  bad or poor quaility of eggs or becauseof  the electricity outage. A friend had the same problems and we were using the same type incubators and we got the eggs from the same place. :cry:
Logged
jchiar
Expert Contributor
Expert Member
******

Karma: 104
Offline Offline

Posts: 745

« Reply #1 on: September 18, 2004, 02:45:09 PM »

sounds more like a humidty  problem than any thing else
Logged
komori35
Guest
« Reply #2 on: September 20, 2004, 08:58:39 PM »

yeah, the humidity factor really makes a  huge difference about the health of the chick.  i had one that hatched out late because the humidity was low.  it lived for exactly 42 hours. all the ones that had hatched out when the humidity was good were fine. go figure.

                                                          -komori
Logged
Pages: [1] Go Up Print 
« previous next »
 

Powered by MySQL Powered by PHP SMF 2.0.15 | SMF © 2017, Simple Machines Valid XHTML 1.0! Valid CSS!