Website Main Page
Forum Main Page

Welcome, Guest. Please login or register.
September 29, 2020, 01:46:47 PM

Login with username, password and session length
Search:     Advanced search
Hope everyone had a great year.  Welcome to 2013.  Our monthly drawings will be starting back soon!
42418 Posts in 6015 Topics by 2375 Members
Latest Member: jg102
* Home Help Search Calendar Login Register
+  That Quail Place Forum
|-+  Our Member's Section
| |-+  That Quail Place ChatRoom
| | |-+  Incubator fail
« previous next »
Pages: [1] Go Down Print
Author Topic: Incubator fail  (Read 1970 times)
phoebedweeby
New Member
**

Karma: 0
Offline Offline

Posts: 5

Personal Text

« on: August 30, 2013, 04:09:53 AM »

  s144 s85
Hi Im new to quail and Ive just got to day 16 of incubating some eggs.  When I got up this morning the heat lamp had blown, I dont know how long it had been out and really want to know will this have done any harm or even killed the chicks. Ive put a new heat lamp in straight away. Does anyone have any advice on what I should do.
Logged
Little Bear Game Farm
Expert Member
*****

Karma: 27
Offline Offline

Posts: 250


Kick 'Em Up - Knock 'Em Down

« Reply #1 on: August 30, 2013, 06:01:15 AM »

Ride it out and find out.  I had our power go down twice this year while incubating and had the incubators down to 80F before I got the generator going.  I did not see much difference in hatch rate.
Logged

Chukar and Pheasant Propogation - Trust my advice based on the knowledge that I have not been doing this very long and don't know a lot more than I do know...  But at least I know that I don't know
phoebedweeby
New Member
**

Karma: 0
Offline Offline

Posts: 5

Personal Text

« Reply #2 on: August 30, 2013, 04:50:56 PM »

Well I will know by the end of this weekend, but Im not getting my hopes up. Fingers crossed. Thanks for your reply agd2
Logged
Pages: [1] Go Up Print 
« previous next »
 

Powered by MySQL Powered by PHP SMF 2.0.15 | SMF © 2017, Simple Machines Valid XHTML 1.0! Valid CSS!