Website Main Page
Forum Main Page

Welcome, Guest. Please login or register.
August 14, 2020, 01:56:37 AM

Login with username, password and session length
Search:     Advanced search
Hope everyone had a great year.  Welcome to 2013.  Our monthly drawings will be starting back soon!
42418 Posts in 6015 Topics by 2375 Members
Latest Member: jg102
* Home Help Search Calendar Login Register
+  That Quail Place Forum
|-+  Raising Gamebirds
| |-+  Incubation
| | |-+  haven't had this before
« previous next »
Pages: [1] Go Down Print
Author Topic: haven't had this before  (Read 1412 times)
jgalo
Senior Member
*****

Karma: 3
Offline Offline

Posts: 117

« on: April 22, 2009, 07:14:57 PM »

I am having Chukar eggs rupture daily a25.  I keep taking them out ( about 25 so far) and have candeled them a week ago to the best of my ability but it keeps happening.  Whats left goes into the hatcher to wsp1mmarrow.  Never had that happen before.  What causes that?


                                    wsp1
                        Please tell O wise ones
Logged
Reeves
Expert Contributor
Expert Member
******

Karma: 151
Offline Offline

Posts: 3269


« Reply #1 on: April 23, 2009, 10:05:02 AM »

Your question (if I am understanding correctly) is related to the top sticky.

Sounds like you misdiagnosed some eggs, which are then rotting in the incubator ?

With that many though, I'd say something killed the embryos in most/all the eggs ?
In this case it could be many things. Lack of O2, bacteria, heat/cold.......
Logged
Pages: [1] Go Up Print 
« previous next »
 

Powered by MySQL Powered by PHP SMF 2.0.15 | SMF © 2017, Simple Machines Valid XHTML 1.0! Valid CSS!