Website Main Page
Forum Main Page

Welcome, Guest. Please login or register.
July 17, 2019, 10:34:16 PM

Login with username, password and session length
Search:     Advanced search
Buy & Sell Gamebirds online!
Click Here for TQP Auction & Ads
42417 Posts in 6015 Topics by 2375 Members
Latest Member: jg102
* Home Help Search Calendar Login Register
+  That Quail Place Forum
|-+  Raising Gamebirds
| |-+  Incubation
| | |-+  Bad hatch Rate
« previous next »
Pages: [1] Go Down Print
Author Topic: Bad hatch Rate  (Read 1804 times)
Coturnix Corner
New Member
**

Karma: 0
Offline Offline

Posts: 2

Personal Text

« on: March 18, 2014, 05:47:30 PM »

 ??? I have a new Coturnix Quail operation. In the beginning when I was setting 10 to 20 eggs I had a 99% hatch rate. Now I am setting 300+ eggs and getting only about 30%. When checking eggs after they comeout of the hatcher, many are completely formed just didnt peep and the majority are either not fertile or not completely formed. What am I doing wrong?????
Logged
BrightBoy
New Member
**

Karma: 0
Offline Offline

Posts: 3

Personal Text

« Reply #1 on: March 18, 2014, 09:07:28 PM »

Has your egg supplier changed, or your delivery mode or handling of pre-set eggs changed, eg temp too hot/cold... old eggs?  That's the only issues that can account for your increase in "infertile" eggs.  Late embryo death in egg before pipping seems to imply there could be a humidity problem or the eggs are being turned to late in their development...   Hard to say...

BB
Logged
Pages: [1] Go Up Print 
« previous next »
 

Powered by MySQL Powered by PHP SMF 2.0.15 | SMF © 2017, Simple Machines Valid XHTML 1.0! Valid CSS!